browse by category or date

After recent Windows 10 System update (I am using Insider Preview), my Xamarin Android Player (XAP) refused to work. Everytime I tried to start the emulator, it will prompt error.

DeviceManager_2016-05-07_01-03-03

Error! The details is in the log file (if you can find it)

Error! The details is in the log file (if you can find it)

Since I don’t know where the log file is located, I just run the VM from VirtualBox. This time, I got more informative error message.
VirtualBox_2016-05-07_00-56-35

Details of my system:

  • Windows 10 Insider Preview. Build 1433.rs1_release.160422-1940
  • VirtualBox 5.0.20 r106931
  • Xamarin Android Player 0.6.5

From the error message, it seems something wrong with the VM’s network option. Looking into VirtualBox’s network settings, I don’t see anything amiss.

File -> Preference

File -> Preference

VirtualBox_2016-05-07_01-38-25

VirtualBox_2016-05-07_01-38-33

The network settings are already follow the recommended values. Perhaps we can find something in Windows’ network settings (Win-R, ncpa.cpl, ENTER)

Right-Click, Properties

Right-Click, Properties

dllhost_2016-05-07_01-45-52

Hmm…VirtualBox NDIS6 Bridged Networking Driver strangely is not checked. Could this be the cause? Let’s just check that and try to start the XAP again.

chrome_2016-05-07_01-51-41

It works! Heng ah! 😀

About Hardono

Hi, I'm Hardono. I am working as a Software Developer. I am working mostly in Windows, dealing with .NET, conversing in C#. But I know a bit of Linux, mainly because I need to keep this blog operational. I've been working in Logistics/Transport industry for more than 9 years.

No Comment

Add Your Comment